const regex = /(?!\n(([^"]*"){2})*[^"]*$)\n/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!\\n(([^"]*"){2})*[^"]*$)\\n', 'g')
const str = `column1rowA "column2rowA" column3rowA column4rowA
column1rowB column2rowB "column3rowB
3Bcont
3Bcont
3Bcont
" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD "column3rowD
3Dcont" column4rowD`;
const subst = `<br>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);