import Foundation
let pattern = #"(?!\n(([^"]*"){2})*[^"]*$)\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
column1rowA "column2rowA" column3rowA column4rowA
column1rowB column2rowB "column3rowB
3Bcont
3Bcont
3Bcont
" column4rowB
column1rowC column2rowC column4rowC
column1rowD column2rowD "column3rowD
3Dcont" column4rowD
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<br>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)