// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^l+[0-9]+@hotmail.com$").unwrap();
let string = "samuel7348@hotmail.com
aa1@hotmail.com
some.day.ill.be.saturday.night1995@hotmail.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}