$re = '/#.*\btester\b|\b(tester)\b/';
$str = 'tester, #tester
test tester # test tester
tester';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);