const regex = new RegExp('@(\\w+?)@', 'g')
const str = `http://whatever.org/?title=@Title@¬e=@Note@`;
const subst = `{\1}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);