re = /@(\w+?)@/
str = 'http://whatever.org/?title=@Title@¬e=@Note@'
subst = '{\\1}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result