#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(^if|^while|[ ;}\n]if|while)[ ]*([(]([^()]|(?2))*[)])"
Local $sString = "if(something)" & @CRLF & _
"while(somethin*(sdds(d)(f)f(s)e))gif(sine)" & @CRLF & _
"hile()" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")