re = /^<([^>]+)>(?:(?!\1).)+<\/\1>$/m
str = '<center>Random question</center>
center Text
Text center
<center>Random center question</center>
<p>Random question</p> <strong>center</strong>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end