$re = '/^\+(?:[0-9] ?){6,14}[0-9]$/';
$str = '+44 1522 538328111';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);