using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# you define first the basic elements (as for a lexer) with named groups
(?(DEFINE)
(?<var> [a-z_]\w*)
(?<dqstr> (?<="") [^\\""]*+ (?s:\\.[^\\""]*)*+ (?="") )
(?<sqstr> (?<=') [^\\']*+ (?s:\\.[^\\']*)*+ (?=') )
(?<string> \g<dqstr> | \g<sqstr> )
(?<num> [0-9]+(?:\.[0-9]+)? )
(?<value> \g<string> | \g<num> )
(?<comp> [!><=]= | =?[><])
)
# Then you write the pattern using these named groups
(?J) # allow duplicate named groups
# variable op value
(?<key> \g<var> ) \h* \g<comp> \h* [""']?(?<val> \g<value>) [""']?
| # OR
# value op variable
[""']?(?<val> \g<value>) [""']? \h* \g<comp> \h* (?<key> \g<var> )
";
string input = @"type == 'prova' && padposition == ""stefano"" or 10>var_name";
RegexOptions options = RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}