$re = '~# you define first the basic elements (as for a lexer) with named groups
(?(DEFINE)
(?<var> [a-z_]\w*)
(?<dqstr> (?<=") [^\\\\"]*+ (?s:\\\\.[^\\\\"]*)*+ (?=") )
(?<sqstr> (?<=\') [^\\\\\']*+ (?s:\\\\.[^\\\\\']*)*+ (?=\') )
(?<string> \g<dqstr> | \g<sqstr> )
(?<num> [0-9]+(?:\.[0-9]+)? )
(?<value> \g<string> | \g<num> )
(?<comp> [!><=]= | =?[><])
)
# Then you write the pattern using these named groups
(?J) # allow duplicate named groups
# variable op value
(?<key> \g<var> ) \h* \g<comp> \h* ["\']?(?<val> \g<value>) ["\']?
| # OR
# value op variable
["\']?(?<val> \g<value>) ["\']? \h* \g<comp> \h* (?<key> \g<var> )
~xi';
$str = 'type == \'prova\' && padposition == "stefano" or 10>var_name';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);