const regex = /^[1-9][0-9]{0,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[1-9][0-9]{0,3}$', 'gm')
const str = `0100
0001
0050
1020
1000
9129
abcd
123x
1234
0
1
12
999
099`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}