# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"SELECT([^\"]|\n|\"[^\";]*\")*LIMIT([^\"]|\n|\"[^\";]*\")*\";"
test_str = ("// blah\n"
"$SelQuery = \"SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid\n"
" FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH\n"
" WHERE C.id=QR.cid\n"
" AND QR.rhid=RH.id\n"
" AND QR.catid='\".$objArray['catid'].\"'\n"
" AND QR.catid=QC.id\n"
" AND C.id IN($SelClids)\n"
" LIMIT $page_no,$this->Limit\";\n\n"
"$SelQuery = \"SELECT DISTICNT C.firstname,C.lastname,C.id as clientid,QC.category_name,QR.cid,QR.catid,QR.rhid\n"
" FROM cms_question_report QR, cms_clients C,cms_questioncategory QC ,cms_reporthistory RH\n"
" WHERE C.id=QR.cid\n"
" AND QR.rhid=RH.id\n"
" AND QR.catid='\".$objArray['catid'].\"'\n"
" AND QR.catid=QC.id\n"
" AND C.id IN($SelClids)\";\n\n"
"\"SELECT LIMIT\";\n"
"LIMIT\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.