# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:\|\s*|^)\d+)[ .](\d+)/\1\2/g;t' <<< "|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15"