import Foundation
let pattern = #"((?:\|\s*|^)\d+)[ .](\d+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
|12 546,123 | AROME 53.213 | 52 321,15
| 2.546,123 | AROME 53 213 |152.321,15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)