package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:729)?0*?123(?:[\x{00BF}-\x{1FFF}\x{2C00}-\x{D7FF}a-zA-Z])*\.(?:jpg|png))`)
var str = `123.jpg
123× ×™×¡×™×•×Ÿ.jpg
123.jpg
729000123× ×™×¡×™×•×Ÿ.jpg
729000123test.jpg
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}