// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((((H|h)(T|t)|(F|f))(T|t)(P|p)((S|s)?))\:\/\/)?(www.|[a-zA-Z0-9].)[a-zA-Z0-9\-\.]+\.[a-zA-Z]{2,6}(\:[0-9]{1,5})*(\/($|[a-zA-Z0-9\.\,\;\?\'\\\+&%\$#\=~_\-]+))*$").unwrap();
let string = "http://sites.google.com
https://192.168.0.1
www.google.com
http://google.com
ftp://user:password@www.example.com
news://www.example.com
http://www.test.com?pageid=123&testid=1524
http://www.⌘.ws/
http://www.foo.com/blah_blah_(wikipedia)
http://www.test.com/?pageid=123&testid=1524
http://www,google.com
http://w,google.com
http://q,google.com
htftp://www.google.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}