import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"([^,]*),([^,]*)\"";
final String string = "Day,Total,,,,,\"48,303\",100.00%,\"41,429\",100.00%,\"9,302\",100.00%,\"3,948\",100.00%\n"
+ "Day,\"Nov 11, 2014\",,,,,\"7,050\",14.60%,\"6,428\",15.52%,\"1,646\",17.70%,698,17.68%\"";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}