#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$"
Local $sString = "10:05am[Mon-Fri Only]" & @CRLF & _
"10:05am[Tue]" & @CRLF & _
"10:05pm[Wed-Fri]" & @CRLF & _
"10:05am[Thu Only]" & @CRLF & _
"9:05am[Sat-Sun]" & @CRLF & _
"10:05am[Fri]" & @CRLF & _
"10:05am[Sun]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")