package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$`)
var str = `10:05am[Mon-Fri Only]
10:05am[Tue]
10:05pm[Wed-Fri]
10:05am[Thu Only]
9:05am[Sat-Sun]
10:05am[Fri]
10:05am[Sun]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}