use strict;
my $str = '10:05am[Mon-Fri Only]
10:05am[Tue]
10:05pm[Wed-Fri]
10:05am[Thu Only]
9:05am[Sat-Sun]
10:05am[Fri]
10:05am[Sun]';
my $regex = qr/^\d{1,2}:\d{1,2}([ap])m\[(Mon|Tue|Wed|Thu|Fri|-){1,} Only\]$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}