re = /((\w+ ){5})group to(( \w+){5})/
str = 'A repeated capturing group will only capture the last iteration. Put a capturing group around the repeated group to capture all iterations or use a non-capturing group instead if you\'re not interested in the data'
# Print the match result
str.match(re) do |match|
puts match.to_s
end