re = /^([abcd])((?!\1)[abcd])?((?!\1|\2)[abcd])?((?!\1|\2|\3)[abcd])?$/m
str = 'abcd
abc
aaa
ab
a
abb
abcb
dbca
dbda
bdba
cbad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end