$re = '/(?:(?!\n|\r)\s)/m';
$str = 'foo bar
bar foo
foobar nb hgh h
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);