#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\[description\]:((?:.+\n?)*)"
Local $sString = " [type]: mail" & @CRLF & _
" [category]: Values" & @CRLF & _
" [service]: testing" & @CRLF & _
" [description]: Testing out automapping of email" & @CRLF & _
" Line break Testing out automapping of email" & @CRLF & _
" Line break Testing out automapping of email"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)