#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(https://github\.com/)?(?P<namespace>[^/\s]+)\/(?P<repo>[^#\s]+)(#|/pull/)(?P<pr_id>\d+)"
Local $sString = "/packit-dev test --identifier my-id-1 --labels label1,label2 namespace-1/repo-1#33" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --identifier my-id-2" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --labels label1 --identifier my-id-2" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --labels label1 --id my-id-2" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2 " & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE=bundle --labels label1" & @CRLF & _
"/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE= --labels label1" & @CRLF & _
"/packit-dev test https://github.com/kontura/librepo/pull/4" & @CRLF & _
"/packit-dev test https://github.com/namespace-3/repo-3/pull/42 --identifier my-id-3" & @CRLF & _
"/packit-dev test --labels label1,label2 https://github.com/namespace-4/repo-4/pull/99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")