use strict;
my $str = '/packit-dev test --identifier my-id-1 --labels label1,label2 namespace-1/repo-1#33
/packit-dev test namespace-2/repo-2#36 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --identifier my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 --id my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --labels label1 -i my-id-2
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE=bundle --labels label1
/packit-dev test namespace-2/repo-2#36 --env INSTALL_TYPE= --labels label1
/packit-dev test https://github.com/kontura/librepo/pull/4
/packit-dev test https://github.com/namespace-3/repo-3/pull/42 --identifier my-id-3
/packit-dev test --labels label1,label2 https://github.com/namespace-4/repo-4/pull/99';
my $regex = qr/(https://github\.com/)?(?P<namespace>[^/\s]+)\/(?P<repo>[^#\s]+)(#|/pull/)(?P<pr_id>\d+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}