// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)[:]\s*(\"\w*\")"#).unwrap();
let string = "\"ElevationFilenameIn\": \"Input raster elevation file\",
\"TargetCRS\": \"Target vertical coordinate reference system Type\",
\"TargetCRScode\": \"Target vertical coordinate system Code\",
\"TargetCRSfile\": \"The projection (.prj) file in shoebox to be used for this inputfile\",";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}