re = /^\S+\s*(\S+)\s*(\S+)\s*(\S+).*$/m
str = 'I have 1000 dollars
I want my pet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end