using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-zА-Яа-я]+([\-`][A-Za-zА-Яа-я]+)*$";
string input = @"TheOldName
the`example`s
The-new-name
name`s
`no-match";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}