re = /(?!^)(?=(?:\d{3})+$)/m
str = '111222333444
11222333444'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result