$re = '/\[\#(.*?)\]/';
$str = '[#20160708-0020] Hello [SQL] blah blah';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);