const regex = /(?:(?:https?)+\:\/\/+[a-zA-Z0-9\/\._-]{1,})+(?:(?:jpe?g|png|gif))/gsim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:https?)+\\:\\\/\\\/+[a-zA-Z0-9\\\/\\._-]{1,})+(?:(?:jpe?g|png|gif))', 'gsim')
const str = `https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.png
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jph
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jjg
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.bmp
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.gif
https://pp.vk.me/c624121/v624121992/3cf22/YRIx_w-QySg.jpeg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}