#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?im)^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) "
Local $sString = "ANNEKA VANHOVEN BAKKER" & @CRLF & _
"HENRIETTA VON DER GRAAF" & @CRLF & _
"CAROLINE VAN OOSTEN DE WINKEL" & @CRLF & _
"MARC DE VRIES VAN JONG" & @CRLF & _
"JOHN SMITH"
Local $sSubst = "$1$2-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)