use strict;
my $str = 'ANNEKA VANHOVEN BAKKER
HENRIETTA VON DER GRAAF
CAROLINE VAN OOSTEN DE WINKEL
MARC DE VRIES VAN JONG
JOHN SMITH';
my $regex = qr/^(.*? (?:VAN|VON|DE)) |((?<!^)\G\w+) /imp;
my $subst = '$1$2-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";