re = /^.{0,64}(@)(?=.+\..+).{0,255}$/
str = 'tom@1234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123456789012345678901234567890123.5'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end