using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))";
string input = @"JLX\BVA12345
JLX\bva12345
JLX\e123456
JLX\c123456
JLX\E123456
JLX\C123456";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}