// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)JLX\\(?:(?:\w(\w{2}\d{5}))|(\w\d{6}))").unwrap();
let string = "JLX\\BVA12345
JLX\\bva12345
JLX\\e123456
JLX\\c123456
JLX\\E123456
JLX\\C123456";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}