using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z][^,]+),\s([A-Z]{2})";
string input = @"Fort Worth, TX
This is Forth Worth, TX
We are looking for someone from Columbus, MS.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}