$re = '/([A-Z][^,]+),\s([A-Z]{2})/';
$str = 'Fort Worth, TX
This is Forth Worth, TX
We are looking for someone from Columbus, MS.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);