import re
regex = re.compile(r"([A-Z][^,]+),\s([A-Z]{2})")
test_str = ("Fort Worth, TX\n"
"This is Forth Worth, TX\n"
"We are looking for someone from Columbus, MS.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")