#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\s*("{0,1})(;|\n){1}"
Local $sString = ""this "; is ; a test; obviously " & @CRLF & _
"I need ;to escape ;"trailing whitespace ";"from a CSV "" & @CRLF & _
"Hope doing ;"this through "; a regex replace" & @CRLF & _
"in python ;"will be fast ";for huge files "
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)