const regex = new RegExp('\\s*("{0,1})(;|\\n){1}', 'g')
const str = `"this "; is ; a test; obviously
I need ;to escape ;"trailing whitespace ";"from a CSV "
Hope doing ;"this through "; a regex replace
in python ;"will be fast ";for huge files `;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);