use strict;
my $str = 'prežrať/RNE/IGE
prežrieť/Z
prežrúc/zZ/32
prežuť/cgrj';
my $regex = qr//[^/]*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";