using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^GET \S{0,100}\/\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\d){2} HTTP";
string input = @"GET /?lpypmp=eirieisifjtjgkulimwndgqgdgqh&yblb=6&dgqgdgqh=7 HTTP/1.1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}