import Foundation
let pattern = #"^GET \S{0,100}\/\?[a-z]{2,10}=[a-z]{5,35}(&[a-z]{2,10}=\d){2} HTTP"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"GET /?lpypmp=eirieisifjtjgkulimwndgqgdgqh&yblb=6&dgqgdgqh=7 HTTP/1.1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}