# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\[)([^\]]*)(\])/<b>$2<\/b>/g;t' <<< "I don't [wanna] be a bus [driver] all my [life]"