using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[)([^\]]*)(\])";
string substitution = @"<b>$2</b>";
string input = @"I don't [wanna] be a bus [driver] all my [life]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}