use strict;
my $str = 'I don\'t [wanna] be a bus [driver] all my [life]';
my $regex = qr/(\[)([^\]]*)(\])/p;
my $subst = '<b>$2</b>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";