$re = '/(\[)([^\]]*)(\])/';
$str = 'I don\'t [wanna] be a bus [driver] all my [life]';
$subst = "<b>$2</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;